Page 1 of 1

Game won't Launch

Posted: Wed Oct 31, 2018 4:12 pm
by Johny

So I use a MacBook to play Craftland (not played in a while though) and for some reason the app won't launch. I've tried deleting/re-downloading and also using the technic launcher but still the same outcome.

What happens when I open the app is the app opens a window titled "Craftland LauncherLoader" before it shows very quickly "Starting launcher with 2048Mb Memory". The Craftland icon then disappears and re-appears like the launcher is about to open, but instead it just disappears and nothing happens..

I managed to find some code that I think might be relevant (It's probably not) to why it's happening but I really don't understand technology tbh.

"Last login: Wed Oct 31 16:02:25 on ttys000
Johns-MBP:~ johng$ /Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/bin/java ; exit;
Usage: java [-options] class [args...]
(to execute a class)
or java [-options] -jar jarfile [args...]
(to execute a jar file)

where options include:
-d32 use a 32-bit data model if available
-d64 use a 64-bit data model if available (implies -server, only for x86_64)
-client to select the "client" VM
-server to select the "server" VM
-jvm is a synonym for the "client" VM [deprecated]
-hotspot is a synonym for the "client" VM [deprecated]
The default VM is client.

-cp <class search path of directories and zip/jar files>
-classpath <class search path of directories and zip/jar files>
A : separated list of directories, JAR archives,
and ZIP archives to search for class files.
set a system property
enable verbose output
-version print product version and exit
require the specified version to run
-showversion print product version and continue
-jre-restrict-search | -jre-no-restrict-search
include/exclude user private JREs in the version search
-? -help print this help message
-X print help on non-standard options
enable assertions
disable assertions
-esa | -enablesystemassertions
enable system assertions
-dsa | -disablesystemassertions
disable system assertions
load native agent library <libname>, e.g. -agentlib:hprof
see also, -agentlib:jdwp=help and -agentlib:hprof=help
load native agent library by full pathname
load Java programming language agent, see java.lang.instrument
show splash screen with specified image
Saving session...
...copying shared history...
...saving history...truncating history files...

[Process completed]"

If someone could help me fix this so that I can start playing again that would be fabulousssss. :worship: :cry:

J :angel:

Re: Game won't Launch

Posted: Thu Nov 01, 2018 9:35 pm
by Johny
Okay update guys: I somehow managed to fix this. For future reference if someone else gets this same problem, my Mac was running the wrong version of java even though I had the latest one installed. It turns out that I had to manually set the java version in terminal -headache-.

Re: Game won't Launch

Posted: Fri Nov 02, 2018 2:24 am
by Beandon
Nicely done! Glad you could figure it out! :thumbsup:

See you in game!